Проверка что ячейка не пустая в excel
Перейти к содержимому

Проверка что ячейка не пустая в excel

  • автор:

Использование COUNTA для подсчета ячеек, которые не являются пустыми

Предположим, вам нужно узнать, все ли часы работы над проектом были введены участниками вашей команды на листе. Иными словами, необходимо подсчитать ячейки с данными. И, чтобы усложнить ситуацию, данные могут быть не числовыми. Некоторые из участников вашей команды, возможно, ввели значения заполнителей, например «TBD». Для этого используйте функцию COUNTA.

Функция СЧЁТЗ

Эта функция подсчитывает только ячейки с данными, но имейте в виду, что «данные» могут включать пробелы, которые не видны. Да, в этом примере пробелы можно подсчитать самостоятельно, но представьте, что книга велика. Итак, чтобы использовать формулу:

  1. Определить диапазон ячеек, которые нужно подсчитать. В приведенном примере это ячейки с B2 по D6.
  2. Выделить ячейку, в которой нужно отобразить результат. Назовем ее ячейкой результата.
  3. Ввести формулу в ячейке результата или строке формул и нажать клавишу ВВОД: =СЧЁТЗ(B2:D6)

Можно также подсчитать ячейки из нескольких диапазонов. В этом примере подсчитывается количество ячеек в B2–D6 и в B9–D13.

Использование функции СЧЁТЗ для подсчета ячеек в двух диапазонах

Вы увидите, что Excel выделяет диапазоны ячеек, а при нажатии клавиши ВВОД отображается результат:

Результат функции СЧЁТЗ

Если известно, что нужно учесть только числа и даты, но не текстовые данные, используйте функцию СЧЕТ.

Другие способы подсчета количества ячеек с данными

  • Подсчет символов в ячейках
  • Подсчет количества вхождений значения
  • Определение количества уникальных значений среди дубликатов

Использование функции ЕСЛИ для проверки ячейки на наличие символов

Иногда требуется проверить, пуста ли ячейка. Обычно это делается, чтобы формула не выводила результат при отсутствии входного значения.

Ячейка E2 содержит формулу =ЕСЛИ(D2=1;

В данном случае мы используем ЕСЛИ вместе с функцией ЕПУСТО:

  • =ЕСЛИ(ЕПУСТО(D2);»Пустая»;»Не пустая»)

Эта формула означает: ЕСЛИ(ячейка D2 пуста, вернуть текст «Пустая», в противном случае вернуть текст «Не пустая»). Вы также можете легко использовать собственную формулу для состояния «Не пустая». В следующем примере вместо функции ЕПУСТО используются знаки «». «» — фактически означает «ничего».

Проверка пустоты ячейки — ячейка E2 содержит формулу =ЕСЛИ(ЕПУСТО(D2);

Эта формула означает: ЕСЛИ(в ячейке D3 ничего нет, вернуть текст «Пустая», в противном случае вернуть текст «Не пустая»). Вот пример распространенного способа использования знаков «», при котором формула не вычисляется, если зависимая ячейка пуста:

  • =ЕСЛИ(D3=»»;»»;ВашаФормула()) ЕСЛИ(в ячейке D3 ничего нет, не возвращать ничего, в противном случае вычислить формулу).

Проверка что ячейка не пустая в excel

Страницы: 1

«Проверка данных» пустой ячейки

Пользователь

Сообщений: 13 Регистрация: 01.01.1970

30.11.2012 12:32:35

давно и успешно работаю с Excel и уже привык, что пустая ячейка в документе воспринимается как «0» (ноль). При этой условности всё выполнялось нормально, но вот решил освоить функцию «Проверка данных» вкладки «Данные» и столкнулся со следующей проблемой: при вводе следующих параметров «Проверки вводимых значений» — «Тип данных»: «Целое число», «Условие»: «больше», «Минимум»: «0» выполняется проверка только ячейки с явно введённым нулём, т.е. аналогичный результат для пустой ячейки не выполняется. Почему в данном случае средство «Проверка данных» (см. http://office.microsoft.com/ru-ru/excel-help/HA001034657.aspx) работает по-разному для пустой и нулевой ячейки?
P.S. Эксперементировал с настройками, как указано здесь:
http://office.microsoft.com/ru-ru/excel-help/HP010070461.aspx
и здесь:
http://office.microsoft.com/ru-ru/excel-help/HP010062392.aspx , —
ответа так и не получил.

Сообщений: 61042 Регистрация: 14.09.2012

Контакты см. в профиле

30.11.2012 12:46:58

привык, что пустая ячейка в документе воспринимается как «0» (ноль). Отвыкайте 🙂 Дело в том, что ПУСТАЯ ячейка и НОЛЬ — это разные вещи.

Как поставить условие в Excel «Если не пусто, то. «

Функция в Excel «Если не пусто» — возможность проверить факт заполнения ячейки, чтобы формула не выводила результат при отсутствии значения. Кроме того, можно задать другой параметр, чтобы опция выводила нужные надписи — «Истина» или «Ложь», «Сдал» или «На пересдачу», «Продано» или «В резерве» и т. д. Ниже рассмотрим особенности этой опции и нюансы ее применения.

Как работает условие Excel

Задача функции Эксель не пустая ячейка или официально «ЕПУСТО — проверка наличие числа, текста или формулы. К примеру, если в ячейке имеется какое-то число, приложение выводит параметр «ЛОЖЬ». Если же в ней что-то стоит, отображается «ИСТИНА». В Эксель функция «ЕПУСТО» является логической, а ее суть в проверке какого-либо условия. По такому же принципу работают и иные опции Excel — «ЕЧИСЛО», «ЕССЫЛКА» и другие.

Здесь выполняется условие Excel и, если ячейка не пустая, то значение будет «ЛОЖЬ» или другую надпись. Общее обозначение функции — =ЕПУСТО (значение). Аргумент для этой опции обязателен для заполнения и может иметь вид ссылки на одну или несколько элеметов таблицы, где нужно определить какие-либо данные.

Базовые особенности опции для Excel:

  • если в роли аргумента передано какое-то значение, к примеру, «Истина», «Текст» или «12», результатом выполнения будет ЛОЖЬ;
  • запись с аргументом АДРЕС (x;y)всегда возвращает ЛОЖЬ, ведь эта функция ведет к ссылке на ячейку или непустой параметр;
  • при необходимости использовать формулу не пустой ячейки Excel для нескольких граф, можно выделить нужное число и ввести опцию =ЕПУСТО с аргументом в виде диапазона;
  • при желании возврата параметра ИСТИНА, если в секции не пусто, можно дополнительно использовать функцию НЕ.

Как поставить формулу Excel

Теперь разберемся, как поставить, если не пустое значение ячейки Эксель и использовать эту опцию. В большинстве случаев применяется ЕСЛИ и опцию ЕПУСТО. При этом полный вид имеет следующий вид — =ЕСЛИ(ЕПУСТО(D2);»Пустая»;»Не пустая»). Здесь ЕСЛИ означает, что при пустой D2-ячейке возвращается текст «Пустая», а если это не так — «Не пустая». Как вариант, можно использовать какую-то свою подставку (об этом ниже).

Следующий вариант отображения функции Excel, если не пусто, то формула — =ЕСЛИ(D3=»»;»Пустая»;»Не пустая»). Здесь в ситуации, если в D3 нет никакого параметра, отображается первая надпись, а в ином случае — Вторая. В качестве альтернативы можно использовать следующий вариант отображения — =ЕСЛИ(D3=»»;»»;ВашаФормула()).

Дополнительный момент

При анализе опции Эксель не равно пусто нужно понимать, что опция ЕПУСТО () проверяют только одну графу. Но бывают ситуации, когда необходимо проверить сразу несколько. В таком случае применяется функция СЧИТАТЬПУСТОТЫ(). Если в ячейках ничего не содержится, то указанная выше опция будет считать даже эти секции вместе с заполненными.

В ситуации, когда нужно узнать, есть ли хотя бы одна незаполненная ячейка в таблице Excel между В7 и В12, нужно использовать формулу = ЕСЛИ(СУММ(—ЕПУСТО(B7:B12));ИСТИНА). Для ответа, имеется ли хотя бы одна заполненная секция в В7 и В12, нужно сделать следующую запись — = НЕ(ЕПУСТО(B7:B12)).

Примеры, когда будет полезна функция в Excel

Эксель формула, если ячейка не пустая, применяется во многих случаях, когда нужно определить заполнение какой-либо графы. Чаще всего это делается для того, чтобы после расчета не выдавался результат при отсутствии входного параметра.

Если же говорить о практическом применении в Excel, можно использовать метод для заполнения таблицы со студентами, которые сдали или не сдали экзамен. В такой ведомости будет видно, кто из учащихся справился с экзаменом, а кто его провалил и отправился на пересдачу. При таком раскладе в столбце выводится строка «Сдал» возле граф, где имеется оценка, или «На пересдачу» возле тех лиц, которые провалили экзамен.

При этом формула Excel записывается в следующем формате: =ЕСЛИ(ИЛИ(ЕПУСТО(B4);B3=2);»На пересдачу»;»Сдал»). Здесь команда ЕСЛИ проверяет возвращаемый результат ЕПУСТО для определенного диапазона секций. Предварительно нужно выделить секции таблицы, для которых проводится расчет. Результатом выполнения функции является появление надписей «Сдал» или «На пересдачу».

Далее можно сделать форматирование в Excel:

  • Выделите нужные ячейки, а далее войдите в «Главная» и «Стили». Здесь найдите «Условное форматирование» и «Создать правило».

  • В окне «Создание правила форматирования» выберите функцию «Использовать формулы для определения …» и введите формулу ИЛИ(ЕПУСТО(В3);В3=2).
  • Жмите на «Формат», а после укажите в графе «Формат ячеек» красный цвет для заливки.
  • Подтвердите действие.

Теперь в тех ячейках, в которых не заполнено и записано «На пересдачу» происходит заливка красным цветом.

Аналогичный принцип можно использовать и в других сферах, к примеру, при прохождении медицинского осмотра в предприятии, продаже оборудования и т. д. Единственное, что меняется — значение в колонке Excel, где пусто или не пусто.

Теперь вы знаете, как задается условие Excel, если не пустые или незаполненные ячейки, как реализовать, и где использовать эту функцию. В комментариях расскажите, пригодились ли вам приведенные выше рекомендации, и какие еще инструменты можно использовать.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *