Почему в openserver открывается только localhost
Перейти к содержимому

Почему в openserver открывается только localhost

  • автор:

Форум

Как получить доступ к сайту который на localhost

Обсуждение проблем в работе сборки

Первое новое сообщение • 3 сообщения • Страница 1 из 1

qwelip Сообщения: 3 Зарегистрирован: 10 май 2023, 21:46

Как получить доступ к сайту который на localhost

Не имею опыта работы с данным ПО, посмотрел доку, почитал форум, не нашел ответа. Спасибо заранее за помощь!

Сделал билд проекта, положил его в папку с доменами. Если настраивать сервер с IP 127.0.0.1 то локально все работает. Но мне важно по локальной сети (с планшета) получить доступ на сайт, поэтому перенастраиваю IP сервера на адрес локальной сети. Пытаюсь зайти по локальному адресу с другого устройства, но тут уже возникают ошибки в коде. После небольшого гуглежа выясняю, что мой проект нужно запускать с адреса localhost чтобы не было ошибок и все работало. И вот собственно вопрос — как мне запустить сервер на адресе localhost и одновременно отдать его в локальную сеть? Если вопрос глупый, прошу прощения, пытался найти ответ, но без успеха.

qwelip Сообщения: 3 Зарегистрирован: 10 май 2023, 21:46

Форум

Открывает только localhost , созданные сайты открывать отказывается

Обсуждение проблем в работе сборки
Первое новое сообщение • 4 сообщения • Страница 1 из 1
Revizorro Сообщения: 2 Зарегистрирован: 28 дек 2015, 20:07

Открывает только localhost , созданные сайты открывать отказывается

ОС Windows 10 64 бит, Open server версия 5.2.3 64-бит. Открывает только localhost , в меню программы созданные сайты есть, в браузере не открывает. Прокси сервер отключен, файервола нет. Вручную вписываю в файл hosts адрес сайта, сохраняю, начинает видеть, при рестарте файл перезаписывается и опять та же песня. В настройках программы поставил галочку не перезаписывать файл hosts , не помогает, все равно перезаписывает. Рестарт и все, сайты браузер не видит, только localhost. Куда копать? Уже все нервы вымотал!

Максим Сообщения: 6044 Зарегистрирован: 11 дек 2010, 20:29

Re: Открывает только localhost , созданные сайты открывать отказывается

Revizorro писал(а): В настройках программы поставил галочку не перезаписывать файл hosts , не помогает, все равно перезаписывает.

Если опция включена, то файл вообще никак не используется. Так что ищите, то, что у вас там его перезаписывает. А это могут быть: Касперский, Доктор веб, Mail.Ru Защитник, Avira, Comodo и так далее, это у них типа защита файла такая. Так же убедитесь в том что вы выполнили процедуру «первый запуск» в Open Server (нужно для сброса прав доступа к этому файлу).

Revizorro Сообщения: 2 Зарегистрирован: 28 дек 2015, 20:07

Re: Открывает только localhost , созданные сайты открывать отказывается

Откатил Windows в исходное состояние, с сохранением файлов и параметров, все заработало, правда теперь все программы и драйвера переустанавливаю. Началось с того, что почистил ноут прогой Advance system care, сначала упал Denwer, поставил Open Server, та же песня. Пришлось кардинально решить проблему, откаты изменений сделанные программой для чистки, не помогли, контрольные точки в Windows, почему то отсутствовали. Пришлось возвращать всю винду в исходное состояние.

Форум

У меня почему-то на Windows 8.1 сервер запускается нормально, но я не могу войти ни на один домен (например, joomla.25.ru), кроме localhost. Пробовал использовать средства отладки Windows, но они бесполезны!
Раньше использовал Windows XP SP3. Там всё работало отлично.
Если кто знает причину, подскажите, пожалуйста!

Максим Сообщения: 6044 Зарегистрирован: 11 дек 2010, 20:29

Если файл HOSTS недоступен на запись, то программа работает в ограниченном режиме, т.е. доступен только домен localhost. Нужные права доступа к файлу HOSTS выставляет установщик. Так же это можно сделать через пункт меню «Первый запуск» в программе.

Форум

Предыстория проблемы. Создал папку для сайта. Залил туда файлы WP-движка. Проверил существование индексных файлов. Запускаю. Выходит: «Веб-страница по адресу http://******/, возможно, временно недоступна или постоянно перемещена по новому адресу».

Так как это мог быть «Ограниченный режим» доступа, я проверил следующее.
1. Файл «hosts» не защищен и не блокируется.
2. .exe-файл сервера запускается с правами администратора.
3. Все группы пользователей имеют полный доступ.
4. Перестраховался. Запустил сервер через пункт «Запуск от имени администратора».

В логах никаких сообщений о недоступности к «hosts» нет. Но проблема стоит на месте и никуда не уходит. При этом, используя в качестве домена для WP-движка «localhost», все работает прекрасно.

Использую последнюю версию программы «Open Server 4.8.6».
Настройка производится на ОС Windows 7.

Надеюсь проблему описал коротко и ясно. Требуется помощь.
Заранее спасибо!

Максим Сообщения: 6044 Зарегистрирован: 11 дек 2010, 20:29

Если сервер запускается и эти домены после запуска у вас есть в меню, значит с сервером все в порядке. Варианты тогда такие:
1) В браузере или системе настроена работа через прокси.
2) Вы испортили конфигурацию сервера.
3) Перенаправление делает сам WP-движок через файл .htaccess, как что и почему — вам виднее.

S_Yentaltsev Сообщения: 10 Зарегистрирован: 19 май 2012, 00:31

1. В браузере отсутствуют настройки прокси, так как подключение к сети идёт напрямую.
2. Посмеялся. Только я даже не трогал конфигурацию сервера.
3. WP-движок тут не причем, так как создав простой printf-запрос на он не видел «index.php»-файл.

Буду рад услышать другие версии возникшей проблемы.

Максим Сообщения: 6044 Зарегистрирован: 11 дек 2010, 20:29

Сначала посмотрите попадает ли запрос на сервер и каким кодом отвечает сервер (по логам). Потом уже будем что-то предполагать. Если говорить о том что первое приходит в голову, то предполагаю что пустая папка стала у вас корневой из-за того что вы не изучили руководство пользователя.

S_Yentaltsev Сообщения: 10 Зарегистрирован: 19 май 2012, 00:31

1. Последние записи лога с последнего запуска сервера:

2013-06-13 16:54:27 -------------------------------------------- 2013-06-13 16:54:27 Начало процедуры запуска сервера 2013-06-13 16:54:27 Обновление Hosts файла 2013-06-13 16:54:27 Обновление конфигурации MySQL-5.1.69 2013-06-13 16:54:27 Обновление конфигурации Sendmail 2013-06-13 16:54:27 Обновление конфигурации PHP-5.2.17 2013-06-13 16:54:27 Обновление конфигурации PHPMyAdmin 2013-06-13 16:54:27 Обновление конфигурации Apache-2.2.24 2013-06-13 16:54:27 Запуск MySQL-5.1.69 2013-06-13 16:54:28 Запуск Apache-2.2.24 2013-06-13 16:54:28 Проверка состояния сервера 2013-06-13 16:54:41 Веб-сервер успешно запущен!

2. Записи, которые появились в файле hosts после запуска сервера:

# Start Open Server 3f68652cd0ed9b415561c3cf1bc8c4df_hosts 127.0.0.1 localhost 127.0.0.1 sadovod 127.0.0.1 testing

3. Apache-логи после последнего запуска сервера. Возможно что-то тут есть:

[Thu Jun 13 16:54:31 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache] [Thu Jun 13 16:54:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:31 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366) [Thu Jun 13 16:54:32 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:32 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:32 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:32 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:32 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366) [Thu Jun 13 16:54:34 2013] [notice] Apache/2.2.24 (Win32) mod_ssl/2.2.24 OpenSSL/0.9.8y configured -- resuming normal operations [Thu Jun 13 16:54:34 2013] [notice] Server built: Feb 25 2013 22:01:21 [Thu Jun 13 16:54:34 2013] [notice] Parent: Created child process 6124 [Thu Jun 13 16:54:34 2013] [notice] Disabled use of AcceptEx() WinSock2 API [Thu Jun 13 16:54:35 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache] [Thu Jun 13 16:54:35 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:35 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:35 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:35 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:35 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366) [Thu Jun 13 16:54:36 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:36 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:36 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:36 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!? [Thu Jun 13 16:54:36 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366) [Thu Jun 13 16:54:38 2013] [notice] Child 6124: Child process is running [Thu Jun 13 16:54:38 2013] [notice] Child 6124: Acquired the start mutex. [Thu Jun 13 16:54:38 2013] [notice] Child 6124: Starting 32 worker threads. [Thu Jun 13 16:54:38 2013] [notice] Child 6124: Listening on port 443. [Thu Jun 13 16:54:38 2013] [notice] Child 6124: Listening on port 80.

4. При ошибке загрузки страницы выходит ошибка №137:

Ошибка 137 (net::ERR_NAME_RESOLUTION_FAILED): Неизвестная ошибка.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *